1
0
dotfiles/nixos/default.nix
2025-01-15 13:25:47 +11:00

39 lines
891 B
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

{ pkgs, user, ... }:
{
imports = [
../shared
../shared/cachix
];
# Set your time zone.
time.timeZone = "Australia/Melbourne";
# Turn on flag for proprietary software
nix = {
nixPath = [ "nixos-config=/home/${user}/.local/share/nixos-config:/etc/nixos" ];
settings.allowed-users = [ "${user}" ];
package = pkgs.nixUnstable;
extraOptions = ''
experimental-features = nix-command flakes
'';
};
# It's me, it's you, it's everyone
users.users.${user} = {
isNormalUser = true;
extraGroups = [
"wheel" # Enable sudo for the user.
];
shell = pkgs.zsh;
};
environment.systemPackages = import ../shared/packages.nix { inherit pkgs; } ++ (with pkgs; [
# Linux specific packages
gitAndTools.gitFull
]);
fonts.packages = import ../shared/fonts.nix { inherit pkgs; };
system.stateVersion = "21.05";
}