39 lines
891 B
Nix
39 lines
891 B
Nix
{ pkgs, user, ... }:
|
||
{
|
||
imports = [
|
||
../shared
|
||
../shared/cachix
|
||
];
|
||
|
||
# Set your time zone.
|
||
time.timeZone = "Australia/Melbourne";
|
||
|
||
# Turn on flag for proprietary software
|
||
nix = {
|
||
nixPath = [ "nixos-config=/home/${user}/.local/share/nixos-config:/etc/nixos" ];
|
||
settings.allowed-users = [ "${user}" ];
|
||
package = pkgs.nixUnstable;
|
||
extraOptions = ''
|
||
experimental-features = nix-command flakes
|
||
'';
|
||
};
|
||
|
||
# It's me, it's you, it's everyone
|
||
users.users.${user} = {
|
||
isNormalUser = true;
|
||
extraGroups = [
|
||
"wheel" # Enable ‘sudo’ for the user.
|
||
];
|
||
shell = pkgs.zsh;
|
||
};
|
||
|
||
environment.systemPackages = import ../shared/packages.nix { inherit pkgs; } ++ (with pkgs; [
|
||
# Linux specific packages
|
||
gitAndTools.gitFull
|
||
]);
|
||
|
||
fonts.packages = import ../shared/fonts.nix { inherit pkgs; };
|
||
|
||
system.stateVersion = "21.05";
|
||
}
|